[vdr] [ANNOUNCE] VDR developer version 1.3.48

Mikko Salo mikko.salo at ppe.inet.fi
Sun Apr 23 20:54:40 CEST 2006

Hi Klaus,

I've been taking little time off at vdr upgrades, but now that I tried
the new version I've noticed some talked setbacks that new APIVERSION

I'm using Debian and those scripts that came with apt-get distributed
vdr package, so there's problem with scripts to correctly identify vdr
versio from APIVERSION. What I mean is it possible to separate them to
different switches since now if I try running with those scripts I get

/etc/init.d/vdr start
Starting Linux Video Disk Recorder: vdr
Searching for plugins (VDR 1.3.48/1.3.47):find: warning: Unix filenames
usually don't contain slashes (though pathnames do).  That means that
'-name libvdr-*.so.1.3.48/1.3.47' will probably evaluate to false all
the time on this system.  You might find the '-wholename' test more
useful, or perhaps '-samefile'.  Alternatively, if you are using GNU
grep, you could use 'find ... -print0 | grep -FzZ
sed: -e expression #1, char 47: unknown option to `s'

./vdr -V
vdr (1.3.48/1.3.47) - The Video Disk Recorder

It take me for a while to identify where the problem was since those
scripts are always worked perfectly, now they aren't :(
It found out that plugin-loader.sh is effected from this change in vdr
version x.x.xx/x.x.xx handling.
I hope someone of Debian vdr package maintainer is reading this to be

Although this can be fixed fiddling the script, I think they should be
separated with different switches. But since vdr-1.4 is finally going to
be released, this probably isn't gonna happen?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: plugin-loader.sh
Type: application/x-shellscript
Size: 4399 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20060423/be153a19/plugin-loader.bin

More information about the vdr mailing list