[vdr] Help building xine-lib-1.2 --with-external-ffmpeg

Niels Wagenaar n.wagenaar at xs4all.nl
Fri Sep 12 17:08:13 CEST 2008

Op Vr, 12 september, 2008 16:42, schreef Todd Luliak:
> I've been running around in circles trying to get xine-lib-1.2 built with
> external ffmpeg. I currently use 1.2 with CoreAVC and would like to
> explore the h.264 improvements in ffmpeg trunk.
> I am suspecting my ffmpeg configuration/build/installation, but don't know
> what's wrong.
> -- SNIP --
> ff_audio_decoder.c: In function 'ff_audio_decode_data':
> ff_audio_decoder.c:272: error: 'AVCodecContext' has no member named
> 'bits_per_sample'
> ff_audio_decoder.c:325: error: implicit declaration of function
> 'avcodec_decode_audio'
> ff_audio_decoder.c:330: error: 'AVCodecContext' has no member named
> 'bits_per_sample'
> -- SNIP --

Currently I'm starting with a new VDR system on Xubuntu 8.04. And I have
the exact same issue. Latest trunk of ffmpeg and the latest SVN of
xine-lib 1.2.

> xine-lib compiles fine without the external ffmpeg flag, and
> xine-lib-1.1.14 compiles with or without external ffmpeg using the same
> configure options.
> -- SNIP --

I tried it with older version of xine-lib with or without external-ffmpeg,
it failes at the exact same item (SVN, 1.1.14 and 1.1.15 were tested and
have the same problem).

> and the result is the same
> Your help is GREATLY appreciated as I have tried everything I know and
> everything I found
> in searches over the last three days. I'm stumped.

Same here. I did come around how to fix the 'bits_per_sample' message (it
had to do with a change in ffmpeg after a certain revision). However, I'm
not able to resolve the implicit declaration of function
'avcodec_decode_audio' error. But to be honest, I was a bit fedup last

So if anybody can help me (or us ;) with this, that would be great. I was
thinking of send this message to the xine mailinglist, but perhaps some
VDR users know how to fix this.

> -Todd

Niels Wagenaar

More information about the vdr mailing list