[vdr] 451 Grab image failed <- SOLVED!!!

Rene linuxtv at hertell.com
Sun Jan 3 18:23:40 CET 2010

On 31.12.2009 12:56, Thomas Creutz wrote:
> Am 30.12.2009 09:08, schrieb Rene:
>> Thomas Creutz wrote:
>>> Rene schrieb:
>>>> I have had problems in getting screen captures from VDR (VDR
>>>> 1.6.0_p2-r3
>>>> on Gentoo) with with for example:
>>>> svdrpsend.pl grab file.jpg
>>> check your plugins, most plugins can block the device like the
>>> avards-plugin
>> Hi Thomas!
>> This sounds interesting! Never heard about this before.. Is there any
>> way to check which plugins might block the device, or do I just have to
>> start by disabling all, and going through each plugin one-by one?
> yes, this is the best way to find it. Just start with no plugin.. when
> it is possible to grab the image, than one of your plugins block the
> device. (this is also what I did for a while:
> http://www.vdr-portal.de/board/thread.php?postid=809751#post809751)

I tested everything you guys suggested, and ended up booting into older
kernel-versions. I finally found a kernel-version that returned a
suxxesful grab. After this i did a diff on the kernel-config-files, and
found what was missing from my new configs: CONFIG_VIDEO_V4L1_COMPAT=y
(Device Drivers->Multimedia support-> Enable Video For Linux API 1
compatible Layer=y)

Enabling this, recompiling the kernel, replacing the kernel-image and
rebooting my vdr returned the grab-feature of vdr!!

I'm not sure why vdr 1.6.0-2 needs this setting, but anyway this solved
the case.

I hope that if someone has similar problems, that these instructions
help them getting grab to work again!

Best Regards, and have a merry New Year 2010 :-)


More information about the vdr mailing list