[vdr] vdr-xine - skipping audio & video [RESOLVED]

Simon Baxter linuxtv at nzbaxters.com
Fri Jan 8 23:50:09 CET 2010


After literally a year or more, I've finally found the one thing that was
causing my problems with this.

Problem: Any version of vdr-xine above 0.8.0 (and associated xine-lib and
xine-ui from Reinhard's website) caused audio and video skips a few minutes
into watching a recording.  This was indicated by multiple "fixing sound
card drift by XXXX pts" messages in the xine console coinciding with the
video "catching up"

Fix: (too easy, as these things often turn out to be!!!) modify

HOORAY!!!  I'm finally able to move off a 2007 plugin!

Next problem - I can't get vdpau to work.  But I'll start another thread for


----- Original Message ----- 
From: "Simon Baxter" <linuxtv at nzbaxters.com>
To: "VDR Mailing List" <vdr at linuxtv.org>
Sent: Sunday, October 18, 2009 9:57 PM
Subject: [vdr] vdr-xine - skipping audio & video

> Hi - am at my wits end!!!
> I've now tried vdr-xine-0.9.3 with XV and with VDPAU, and several settings 
> in .xine/config for engine.buffers.audio_num_buffers (2300) and 
> engine.buffers.video_num_frames (60) but I still get skips in audio and 
> video when viewing recorded programs - which I don't get in 
> vdr-xine-0.8.0.
> The skips occur at the same time as VDR console messages "buffering xx 
> frames", and start out OK when watching the program but within a few 
> minutes deteriorate further and further.
> I've been trying to upgrade from 0.8.0 since 2007 now - but it's the only 
> version which works flawlessly for me.
> My production box has:
> vdr-1.6.0
> fedora 10 with latest kernel
> fluxbox and X window manager
> latest standard v4l-dvb drivers
> plugins: vdr-xine-0.8.0, iptv, epgsearch, skinenigmang, femon, radio, 
> recstatus, pvrinput.
> xine started with :
> xine --no-splash -Bfpqg --hide-gui -r anamorphic -V 
> xv -Dtvtime:method=Greedy2Frame,cheap_mode=0,pulldown=0,use_progressive_frame_flag=1 
>  --post vdr_video --post vdr_audio 
> vdr://tmp/vdr-xine/stream#demux:mpeg_pes
> I've tested the following
> vdr-1.7.9 with the s2-liplianin drivers
> vdr-1.7.9 with the standard latest v4l-dvb drivers
> vdr-xine various versions from 0.8.1 right up to 0.9.3
> xine-lib-1.2 with VDPAU and with XV output started by either:
> xine --no-splash -Bfpqg --hide-gui -r anamorphic -V 
> vdpau -Dtvtime:method=Greedy2Frame,cheap_mode=0,pulldown=0,use_progressive_frame_flag=1 
>  --post vdr_video --post vdr_audio vdr://tmp/vdr-xine/stream#dex:mpeg_pes
> OR
> xine --no-splash -Bfpqg --hide-gui -r anamorphic -V 
> xv -Dtvtime:method=Greedy2Frame,cheap_mode=0,pulldown=0,use_progressive_frame_flag=1 
>  --post vdr_video --post vdr_audio 
> vdr://tmp/vdr-xine/stream#demux:mpeg_pes
> Can someone share their experiences with VDPAU and vdr-xine, or offer any 
> suggestions???
> Thanks
> Simon
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

More information about the vdr mailing list