[vdr] VDR developer version 1.7.18

Dave vdr at pickles.me.uk
Sun Apr 17 17:15:55 CEST 2011


On Sunday 17 April 2011 15:50:44 Klaus Schmidinger wrote:
> VDR developer version 1.7.18 is now available at
> 
>        ftp://ftp.tvdr.de/vdr/Developer/vdr-1.7.18.tar.bz2
> 
> A 'diff' against the previous version is available at
> 
>        ftp://ftp.tvdr.de/vdr/Developer/vdr-1.7.17-1.7.18.diff

Compiling the new version I get lots of compiler errors in the new dvbhddevice 
plugin. I don't use this plugin and the rest of vdr seems to be fine.

A sample:

g++ -g -O3 -Wall -Woverloaded-virtual -Wno-parentheses -march=native -pipe -
fPIC -c -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -
D_GNU_SOURCE -DPLUGIN_NAME_I18N='"dvbhddevice"' -I../../../include hdffcmd.c
hdffcmd.c: In member function ‘uint32_t 
HDFF::cHdffCmdIf::CmdGetFirmwareVersion(char*, uint32_t)’:
hdffcmd.c:57: error: ‘osd_raw_cmd_t’ was not declared in this scope
hdffcmd.c:57: error: expected ‘;’ before ‘osd_cmd’
hdffcmd.c:59: error: ‘osd_cmd’ was not declared in this scope
hdffcmd.c:65: error: ‘OSD_RAW_CMD’ was not declared in this scope
hdffcmd.c: In member function ‘uint32_t 
HDFF::cHdffCmdIf::CmdGetInterfaceVersion(char*, uint32_t)’:
hdffcmd.c:83: error: ‘osd_raw_cmd_t’ was not declared in this scope
hdffcmd.c:83: error: expected ‘;’ before ‘osd_cmd’
hdffcmd.c:85: error: ‘osd_cmd’ was not declared in this scope
hdffcmd.c:91: error: ‘OSD_RAW_CMD’ was not declared in this scope

# gcc -v
Using built-in specs.
Target: x86_64-manbo-linux-gnu
Configured with: ../configure --prefix=/usr --libexecdir=/usr/lib --with-
slibdir=/lib64 --with-bugurl=https://qa.mandriva.com/ --mandir=/usr/share/man 
--infodir=/usr/share/info --enable-checking=release --enable-
languages=c,c++,ada,fortran,objc,obj-c++,java --build=x86_64-manbo-linux-gnu 
--host=x86_64-manbo-linux-gnu --with-cpu=generic --with-system-zlib --enable-
threads=posix --enable-shared --enable-objc-gc --enable-long-long --enable-
__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --enable-
java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --with-
ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-gtk-cairo --disable-libjava-
multilib --enable-ssp --disable-libssp --disable-werror --with-ppl --with-
cloog --with-python-dir=/lib/python2.6/site-packages
Thread model: posix
gcc version 4.4.3 (GCC) 


Dave



More information about the vdr mailing list