[vdr] Updated patch for vdr 1.7.22 in gentoo

Marc vdr at ekass.net
Wed Jan 4 09:36:14 CET 2012

On 04/01/2012 00:29, René wrote:
> On 03.01.2012 16:12 , René wrote:
>> On 03.01.2012 10:29 , Marc wrote:
>>> * Unifdef sources ... [ ok ]
>>> * Applying local patches
>>> * Applying livebuffer-1.7.22.patch ... [ ok ]
>>> >>> Source prepared.
>> Ok, then i have something fishy going on.. I have the livebufer in the
>> menu, but then as you said most likely it's not applied correctly. I
>> have to check the build-log if it complains something
> Marc,
> The patch is now found by the ebuild, but  it wont' get applied. The 
> problem is just that it does not work. For some reasons it get's 
> errors like "can't find file to patch"...
No, it's still the same problem, the patch applies but you have more 
difference in your source tree when the local patches are applied. You 
can see what parts of the patch don't apply in the log at line 205.

For me, I only have Makefile, config.c and config.h witch differ but you 
have more :
patching file device.c
Hunk #1 FAILED at 18.
patching file dvbplayer.c
Hunk #4 FAILED at 281.
patching file menu.c
Hunk #4 FAILED at 4169.
Hunk #18 FAILED at 4998.

I only use the noepg use flag, did you tried to compile vdr without any 
use flags ? If it works like this, try to add each use flag one by one 
to see where is the problem.



More information about the vdr mailing list