Difference between revisions of "Weather-plugin"

From VDR Wiki
Jump to: navigation, search
(initial)
 
 
(2 intermediate revisions by 2 users not shown)
Line 11: Line 11:
 
==Installation==
 
==Installation==
 
To install ftplib
 
To install ftplib
  +
cd $SOURCEDIR
<pre>
 
  +
tar xvzf ftplib-<VERSION>-src.tar.gz
cd $SOURCEDIR
 
tar xvzf ftplib-<VERSION>-src.tar.gz
+
cd ftplib-<VERSION>/linux
  +
make
cd ftplib-<VERSION>/linux
 
make
+
make install
make install
 
</pre>
 
   
 
and mdsplib
 
and mdsplib
  +
cd $SOURCEDIR
<pre>
 
  +
tar xvzf mdsplib-<VERSION>.tar.gz
cd $SOURCEDIR
 
tar xvzf mdsplib-<VERSION>.tar.gz
+
cd mdsplib-<VERSION>
  +
make
cd mdsplib-<VERSION>
 
make
+
make dmetar
make dmetar
+
make install
  +
ldconfig
make install
 
ldconfig
 
</pre>
 
   
 
For the plugin see [[plugin installation]].
 
For the plugin see [[plugin installation]].
Line 49: Line 45:
 
|}
 
|}
   
[[Category:Plugins]]
+
[[Category:Outdated Plugins]]
   
  +
{{i18n|weather-plugin}}
<!-- Link to german wiki page -->
 
[[de:Weather-plugin]]
 

Latest revision as of 11:35, 25 November 2013

Description

Screenshot

The weather plugin displays the current weather data for a selected area.

Hardware requirements

Software requirements

  • ftplib
  • mdsplib

Installation

To install ftplib

cd $SOURCEDIR
tar xvzf ftplib-<VERSION>-src.tar.gz
cd ftplib-<VERSION>/linux
make
make install

and mdsplib

cd $SOURCEDIR
tar xvzf mdsplib-<VERSION>.tar.gz
cd mdsplib-<VERSION>
make
make dmetar
make install
ldconfig

For the plugin see plugin installation.

Problems

Links

[1] http://www.moldaner.de/vdr Plugin homepage
[2] http://limulus.net/mdsplib METAR Decoder Software
[3] http://nbpfaus.net/~pfau/ftplib ftplib