Multiproto

From LinuxTVWiki
Revision as of 19:41, 23 February 2008 by Goga777 (Talk | contribs)

Jump to: navigation, search

Multiproto is a proposal for version 3.3 of the linux DVB API which includes extensions for cards which support multiple DVB protocols (DVB-S, DVB-S2, DVB-T, DVB-C, DVB-H, ATSC, DSS).

It is an experimental project and is not currently implemented in any released version of Linux. No firm plan has been made for its inclusion in Linux.

Overview/Features

Discuss the features and facets of the project here ... this means you

Design Decisions

explain the choices made ... this means you

Technical Details

give a technical description of how the API change has been implemented ... this means you

Evaluation and Alternatives

explain whether the design goals have been met or not ... this means you

1.===Status and Migration Plan=== explain how a migration from the current API to multiproto could be achieved ... this means you

Making it Work

How to get it:

hg clone http://jusst.de/hg/multiproto

or

http://jusst.de/hg/multiproto/archive/tip.tar.bz2

Drivers

There are currently no in-kernel multiproto drivers.

Provide details of which drivers work with multiproto ... this means you

See

AD-SP400 CI (Twinhan VP-1041)

Hauppauge WinTV-HVR-4000

TT-3200 DVB-S2

provide the details of where the drivers and patches and necessary tools are available ... this means you

provide details of how to compile for recent kernels -- this means you

Sample kernel output

provide the relevant portion of dmesg here

Tuner / DiSEqC / Player support

provide comprehensive details of how to upgrade multimedia applications to work with the new API ... this means you


scan: see patched version at http://jusst.de/manu/scan.tar.bz2

szap: see patched version at http://abraham.manu.googlepages.com/szap.c Also see information about szap2 at http://allrussian.info/thread.php?postid=187408#post187408 and http://www.linuxtv.org/pipermail/linux-dvb/2008-February/023836.html.

mplayer : someone needs to write a patch ... why don't you?

Kaffeine : someone needs to write a patch ... why don't you?

VDR: VDR version 1.5.14 and later require multiproto (v1.5.14 announcement: http://www.linuxtv.org/pipermail/vdr/2008-January/015302.html

MythTV: someone needs to write a patch ... why don't you?


provide details of how to use with DiSEqC -- this means you

External Links