Michael Hunold wrote:
DVB_CARD_TT_BUDGET_CI does not means that the card provides a CI interface, but it means that DiSEqC will be done by the frontend instead of SAA7146 GPIO pins. The name of this define is misleading, sorry. We should rename it. Would you please do so, Michael?Hello Peter,could you please apply these two small patches to the CVS:--- budget-core.c.original Wed Jan 15 21:27:57 2003
+++ budget-core.c Wed Jan 15 21:23:01 2003
@@ -309,7 +309,8 @@
budget->registered=1;
/* init DiSEqC stuff */
- dvb_add_frontend_ioctls (budget->dvb_adapter, budget_diseqc_ioctl, NULL, budget);
+ if(budget->card->type==DVB_CARD_TT_BUDGET)
+ dvb_add_frontend_ioctls (budget->dvb_adapter, budget_diseqc_ioctl, NULL, budget);
I admit that I don't know the hardware, but doesn't the DVB_CARD_TT_BUDGET_CI provide diseqc stuff?
If so, you should probably add the same check to dvb_remove_frontend_ioctls() later on, too.
right. Holger -- Info: To unsubscribe send a mail to listar@linuxtv.org with "unsubscribe linux-dvb" as subject.