Talk:Hauppauge WinTV-HVR-3000

From LinuxTVWiki
Jump to: navigation, search

Yes this is all well and good but... I have ubuntu hardy and recently received a kernel update (2.6.24-15-rt) I had both 2.6.24-12-rt and 2.6.24-15-rt installed but when I was using 2.6.24-15-rt and when I tried to make && make install I get a 'make: *** /lib/modules/2.6.24-12-rt/build no such directory' or something like that. so at first I thought ok the new kernel is ok maybe if I get rid of the old kernel ... no same message. so I do some research and had a look at the INSTALL file and tried 'make rminstall' then 'make clean' then 'make distclean'. And finally then I was able to compile with make and it used the correct directory etc. note this whole time I did have the headers for, at first, both kernels and kernel source installed. please excuse me I'm not a developer ... more like a tester (n00b). Now in the dmesg I find cx88 symbol version errors ...? what have I done?

ubuntu hardy has a problem with linux-kernel-image and linux-ubuntu-modules both having cx88 modules. linux-ubuntu-modules seems to take precedence but installs modules in /lib/modules/2.6.24-15-rt/ubuntu/.... this creates chaos for me.

I've added the way to get the v4l patched sources from Stevet Toth's mercurial repository. Feel free to correct any mistake/delete it, if you think it's bullshit... But I haven't been able to find any other way to build modules on a 2.6.24-21 kernel on Ubuntu (haven't tested on any other distro)... Thanks for this brilliant wiki!!